Project

General

Profile

Unable to retrieve messages

Added by Gjermund over 9 years ago

Hi again!

Can you please look at the attached log and determine if it is yet another issue with my GSM modem or what it is that's preventing me from receiving messages?

The log contains the following from the demo program:
Connect to the modem.
Manually set PDU mode (in terminal window).
Set receiving settings to "Message Indication: Trigger" and "Delete After Receive".
Modem receives a message.


Replies (7)

RE: Unable to retrieve messages - Added by Gjermund over 9 years ago

I'm using a patch of a pre-release of version 1.0.0.4 from other thread (Exception when initializing modem).

RE: Unable to retrieve messages - Added by admin over 9 years ago

Hi,

Please download the patch release 1.0.0.4

Normally message indication comes in the format

+CMTI: "ME",4

From the log file, the modem receives it in the format
+CMTI: "ME",
4

The pattern does not match the expected. We have add in the pattern. Please test and let us know.

RE: Unable to retrieve messages - Added by Gjermund over 9 years ago

It worked! Thanks!

RE: Unable to retrieve messages - Added by Gjermund over 9 years ago

Hi,

We still experience problems with this.
We are now using version 1.0.0.6.

Can you please check the attached log and see if you can discover any problem?

Steps in Messaging Toolkit Demo (Core) to create the log:
Connect to GSM modem.
Send a message from GSM modem to my cell phone. OK.
Activate Message Indication (Trigger).
Send a message from my cell phone to GSM modem. No reaction.
Activate Message Indication (Polling). No reaction.

RE: Unable to retrieve messages - Added by admin over 9 years ago

Hi,

Can you let us know if the modem model that you are using now same as the previous one that you encountered the error?

The message indication received are different again

2010.01.21-10.36.10:Verbose: Received: +CMTI:
"ME",1

RE: Unable to retrieve messages - Added by admin over 9 years ago

Hi,

You can use the patch attached for your further testing.

Do let us know if you still encounter problem

RE: Unable to retrieve messages - Added by Gjermund over 9 years ago

Thanks. We will test it today.

It's a new unit of the same model. Frustrating...

    (1-7/7)