Project

General

Profile

+CMS Error 500

Added by stevensu almost 10 years ago

Hi,

I send a message using my library. Sometime i send it get +CMS Error 500 and then resend again it get +CMGS: OK.. See my log below:

2010-01-18 16:13:31 Sending: AT+CMGS=23
2010-01-18 16:13:32 Received: AT+CMGS=23

2010-01-18 16:13:32 Sending: 07912618485400F931FF0B818091122222F300000B0AEBB41B346EAF41F21F
2010-01-18 16:13:33 Received: 07912618485400F931FF0B818091122222F300000B0AEBB41B346EAF41F21F
2010-01-18 16:13:36 Received:
+CMS ERROR: 500

2010-01-18 16:13:40 Sending: AT+CMGS=23
2010-01-18 16:13:41 Received: AT+CMGS=23

2010-01-18 16:13:41 Sending: 07912618485400F931FF0B818091122222F300000B0AEBB41B346EAF41F21F
2010-01-18 16:13:42 Received: 07912618485400F931FF0B818091122222F300000B0AEBB41B346EAF41F21F
2010-01-18 16:13:45 Received:
+CMGS: 0

OK

What's wrong?


Replies (3)

RE: +CMS Error 500 - Added by admin almost 10 years ago

Hi,

+CMS: 500 is unknown error.

Can you try with a different operator to see if this problem is still encountered?

RE: +CMS Error 500 - Added by stevensu almost 10 years ago

Hi,
Do you remember for the bugs that i ever issued for the CMS Error? I think it happened again. When I test trying sending message w\from the terminal it return CMS Error. But from your demo program it's not...

RE: +CMS Error 500 - Added by stevensu almost 10 years ago

How about when sending message it returns ERROR? And after retry sending again. Sometime it successed and sometime it failed. Now I'm testing using SIEMEN C55..

    (1-3/3)