Project

General

Profile

QRCode decoding issue

Added by admin almost 8 years ago

I'm trying to test some libs for QRCode in C# and yours lib seems very interesting.

I printed some QRCodes onto paper and then I acquired them through a scanner. Note that all the QRCodes have been generated by your lib. The problem is that for one of them the detection/decoding fails (with your code or the Demo app). The risen exception is "..Barcode.NotFoundException".

If I try to scan this code with a common app for iPhone it works without problems...

I send you the image and I hope you could support me.

Thanks a lot


Replies (12)

RE: QRCode decoding issue - Added by admin almost 8 years ago

Hi,

Please try with the attached patch and let us know if it fixed your problem.

Thanks
Regards
admin

RE: QRCode decoding issue - Added by robobot almost 8 years ago

It works much better than the official version.

Can I know what kind of adjustments you have made?

ASAP I give you some statistics about QRCode detection.

Thanks a lot

RE: QRCode decoding issue - Added by robobot almost 8 years ago

On 100 QRcode tested, only 1 fails!

I attach this BMP.

thanks again

RE: QRCode decoding issue - Added by admin almost 8 years ago

Hi,

I generated the QRCode with the demo app. The content is "1.1" with high error correction, and i was able to decode it.

Attached is the image I generated. Could you try again?

Thanks
Regards
admin

1.1.png (4.02 KB) 1.1.png

RE: QRCode decoding issue - Added by robobot almost 8 years ago

The image you give us is correctly decoded by your app.

But we have just probably found the problem! The problem is that when the QRCode is scanned it is stretched respect to the original bitmap (the original size is 168x168 while the stretched is 165x167). So we tried to resize the stretched image allowing gray scale and the code is correctly recognized by your demo application.

I assume that your code doesn't apply any image correction. What do you think about?

I attach the images of the test.

RE: QRCode decoding issue - Added by robobot almost 8 years ago

Another test...

100 QrCode printed with 200 dpi > 1/100 error rate

100 QrCode printed with 400 dpi > 3/100 error rate

I hope this data will be useful for you

RE: QRCode decoding issue - Added by admin almost 8 years ago

Hi,

Currently there is no error correction applied in decoding. We will see if we can add this in the next release.

Thanks
Regards
admin

RE: QRCode decoding issue - Added by robobot almost 8 years ago

ok thanks a lot. I will wait for the new version.

I can add another consideration which can be useful for you. The error rate varies increasing or decreasing the image dimension. The strange thing is that with the original size I found 1/100 error rate, with 0.5*original size is 0/100 and for 0.3 I have 3/100.

I think it continues to be an image correction related problem.

RE: QRCode decoding issue: NEW BIG PROBLEM - Added by robobot almost 8 years ago

Now I have a big problem with you patched lib.

On my computer (Windows 64 bit) I installed your patched version and my app (in VS2010) works fine. Onto others two collegues's PC (Vista 32 bit) we got the same application (with TFS) with the same file and libs. I personally checked the size of the "MessagingToolkit.Barcode.dll" in these 3 PC's and it's the same.

Now the problem is that in these 2 Vista PCs I get, for every scanned QRcode, a "NotFoundException". I cannot understand why it's the problem.

maybe Could it be related to the fact that the patched lib you sent me is a 64 bit version and so it doesn't work in VISTA 32 bit?

thank you

RE: QRCode decoding issue - Added by robobot almost 8 years ago

Delete last post...the problem was the image scaling on Vista and Seven. Problem solved. Thank you

RE: QRCode decoding issue - Added by ronniepi over 6 years ago

I am trying C# barcode generation libs as well. And I just wonder can your lib supports encode & decode Unicode for QR Code?

RE: QRCode decoding issue - Added by admin over 6 years ago

Hi,

Definitely is supported. For encoding, you need to set the character set to UTF-8.

Thanks
Regards
admin

    (1-12/12)